Quantcast

gradle 'mustRunAfter' not compaible with gradle 1.5 (Debian)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

gradle 'mustRunAfter' not compaible with gradle 1.5 (Debian)

Felix Natter
Administrator
hi,

Debian stable uses gradle 1.5 which does not support mustRunAfter
(found in dist.gradle):
  dist.mustRunAfter clean
  createGitTag.mustRunAfter dist

Shall we try to find another solution or shall we ask all affected
developers to use a gradle 2.x update / binary distribution and disallow
backports to older Debian/... versions?

I am ok with using a different gradle distrib. Does this affect other
users? Are you ok with no freeplane backports to Debian stable
(nowadays we rarely do this)?

Best Regards,
--
Felix Natter
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gradle 'mustRunAfter' not compaible with gradle 1.5 (Debian)

Dimitry Polivaev
Administrator
Debian using gradle 1.5 is a shame and IMHO it can not be supported by Freeplane
mustRunAfter has not alternatives

Best regards,
Dimitry

> hi,
>
> Debian stable uses gradle 1.5 which does not support mustRunAfter
> (found in dist.gradle):
>    dist.mustRunAfter clean
>    createGitTag.mustRunAfter dist
>
> Shall we try to find another solution or shall we ask all affected
> developers to use a gradle 2.x update / binary distribution and disallow
> backports to older Debian/... versions?
>
> I am ok with using a different gradle distrib. Does this affect other
> users? Are you ok with no freeplane backports to Debian stable
> (nowadays we rarely do this)?
>
> Best Regards,
> --
> Felix Natter

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gradle 'mustRunAfter' not compaible with gradle 1.5 (Debian)

Volker Börchers
Administrator
Hi,

I don't mind which version Debian provides since I have installed it
from zip. So no problem for me.

Regards,
Volker

Am 02.01.2016 um 17:51 schrieb Dimitry Polivaev [via Freeplane Developer]:

> Debian using gradle 1.5 is a shame and IMHO it can not be supported by
> Freeplane
> mustRunAfter has not alternatives
>
> Best regards,
> Dimitry
>
>  > hi,
>  >
>  > Debian stable uses gradle 1.5 which does not support mustRunAfter
>  > (found in dist.gradle):
>  >    dist.mustRunAfter clean
>  >    createGitTag.mustRunAfter dist
>  >
>  > Shall we try to find another solution or shall we ask all affected
>  > developers to use a gradle 2.x update / binary distribution and disallow
>  > backports to older Debian/... versions?
>  >
>  > I am ok with using a different gradle distrib. Does this affect other
>  > users? Are you ok with no freeplane backports to Debian stable
>  > (nowadays we rarely do this)?
>  >
>  > Best Regards,
>  > --
>  > Felix Natter
>
>
>
> ------------------------------------------------------------------------
> If you reply to this email, your message will be added to the discussion
> below:
> http://freeplane-developer.996965.n3.nabble.com/gradle-mustRunAfter-not-compaible-with-gradle-1-5-Debian-tp819p820.html
>
> To start a new topic under Freeplane Developer, email
> [hidden email]
> To unsubscribe from Freeplane Developer, click here
> <
> NAML
> <
http://freeplane-developer.996965.n3.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
>
Loading...