Java Versions

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Java Versions

BArchibald
Hi all,

Which versions of Java do we officially support?

It seems to me that the current build system is setup to compile mainly for java version 1.5. Although there are some (rather strange) tasks that are happy to aim for Java 1.1 targets.

Can we safely assume that 1.5 is the lowest version we require? (can you even still get Java < 6 ...)

Many thanks,
Blair
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Java Versions

Dimitry Polivaev
Administrator
> Which versions of Java do we officially support?

1.6 and higher

> It seems to me that the current build system is setup to compile mainly for java version 1.5.

Yes, we just have not fixed it yet.

> Although there are some (rather strange) tasks that are happy to aim for Java 1.1 targets.

It comes from times when there was no OSGi and launcher class checked the Java version and
complained if it was smaller than 1.4.

> Can we safely assume that 1.5 is the lowest version we require? (can you even still get Java < 6 ...)

At least 1.6.
Are there any requests for 1.7 for Freeplane 1.4?

Regards,
Dimitry



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Java Versions

BArchibald
Hi Dimitry,

Thanks again for your quick reply. I'll include these bounds for the new build system.

I think we should stick with 1.6 for now as it is still common - what effects, if any, does this have for the JavaFx work?

Many thanks,
Blair


On 15 August 2014 17:21, Dimitry Polivaev [via Freeplane Developer] <[hidden email]> wrote:
> Which versions of Java do we officially support?

1.6 and higher

> It seems to me that the current build system is setup to compile mainly for java version 1.5.

Yes, we just have not fixed it yet.

> Although there are some (rather strange) tasks that are happy to aim for Java 1.1 targets.

It comes from times when there was no OSGi and launcher class checked the Java version and
complained if it was smaller than 1.4.

> Can we safely assume that 1.5 is the lowest version we require? (can you even still get Java < 6 ...)

At least 1.6.
Are there any requests for 1.7 for Freeplane 1.4?

Regards,
Dimitry






If you reply to this email, your message will be added to the discussion below:
http://freeplane-developer.996965.n3.nabble.com/Java-Versions-tp509p510.html
To start a new topic under Freeplane Developer, email [hidden email]
To unsubscribe from Freeplane Developer, click here.
NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Java Versions

Dimitry Polivaev
Administrator
> I think we should stick with 1.6 for now as it is still common - what effects, if any, does this
> have for the JavaFx work?

For JavaFX we need Java 8, but it is still something for the future.

Dimitry

Loading...